Page 3 of 3 FirstFirst 1 2 3
Results 31 to 40 of 40

Thread: Intermittant High Idle (again)

  1. #31
    Member Since
    Feb 2007
    Location
    2000 Proton VX - 0776
    Posts
    9,258
    Thanked: 0
    Can you take a pic of what you unplugged? That seems to be the question of the day.


    Put a smiley after you say that Bub.

  2. #32
    Member Since
    Jan 2005
    Location
    '99 Blk 0089
    Posts
    204
    Thanked: 0
    Ok... so I just followed the PS test procedure and my A/C did not cut out when I turned the steering all the way to the left; and with A/C off, turning steering all the way left did not increase the idle.

    Looks like the PS switch is a good suspect but I just spent 20 min underneath the VX and couldn't see any wires coming out of the PS module... where the hell is it? no one has pics on this forum... seriously?

  3. #33
    Member Since
    Dec 2013
    Location
    1999 Astral Silver 0291, 2000 Kaiser 0419
    Posts
    177
    Thanked: 4
    Can't take pic right now but.........right above PS pump there's a large group of wires and gray connection. About 2in below that is a single wire offshoot, follow that to a small grey connector, unplug it. Did mine, RPM's went from 1400 to 800ish

  4. #34
    Member Since
    Jan 2005
    Location
    '99 Blk 0089
    Posts
    204
    Thanked: 0
    Thank you for the description of where about it is, I will look again. Been on the internet this morning and that PW switch must be made out of gold because it's about $178 from both isuzuparts and O'Reily... Holy Cow !!!

  5. #35
    Member Since
    Dec 2013
    Location
    1999 Astral Silver 0291, 2000 Kaiser 0419
    Posts
    177
    Thanked: 4
    I unplugged mine without replacing it, read that on planetisuzu I think. Haven't noticed a difference with steering

  6. #36
    Member Since
    Apr 2004
    Location
    2000, Ebony, VX, 0370
    Posts
    2,483
    Thanked: 11
    When I had my engine replace a couple of years ago, the shop found that the wire going to the pressure switch on the steering pump was broken/cut and probably had been for a while given the oxidation on the exposed wires. Maybe it was broken from the day I bought it because I never noticed a problem. They order a new switch (and it was expensive) and installed it along with the new engine, but the VX didn't seem to drive any differently.
    "The major difference between a thing that might go wrong and a thing that cannot possibly go wrong is that when a thing that cannot possibly go wrong goes wrong, it usually turns out to be impossible to get at or repair."
    -Douglas Adams, Mostly Harmless

  7. #37
    Member Since
    Jan 2005
    Location
    '99 Blk 0089
    Posts
    204
    Thanked: 0
    I finally found the grey PS switch connector and unplugged it - however, as I lightly pulled up on wire just to see where the h$% this mysterious switch is on the pump, it was not even connected to sensor - looks like it was broken off probably when I had my engine replaced. Anyhow, I was hoping the high idle issue is the switch but I guess not if it was never connected

  8. #38
    Member Since
    May 2018
    Location
    2001 Black Vehicross 0535
    Posts
    21
    Thanked: 4
    Subscribed, mine is doing this intermittent high idle too. So aggravating. Haven't replaced anything yet, but I will be looking into this power steering pressure switch

  9. #39
    Member Since
    Sep 2015
    Location
    1999, white,base,0438
    Posts
    2
    Thanked: 1
    Had similar problem. Ended up being the Idle control valve

  10. #40
    Member Since
    Jan 2015
    Location
    1999 Ebony VX, 0209
    Posts
    549
    Thanked: 15
    There is a wire coming from the power steering pump. Unplug it.
    --------
    VX Status: Running Great! Build is coming along nicely...

Similar Threads

  1. High Idle suddenly =/
    By Breezy in forum VX Troubleshooting...
    Replies: 21
    Last Post: 11/19/2011, 04:47 AM
  2. Another high idle problem
    By RAZ in forum VX Troubleshooting...
    Replies: 20
    Last Post: 07/13/2011, 12:59 PM
  3. High idle/ high power steering pressure?
    By Rene M in forum VX Troubleshooting...
    Replies: 1
    Last Post: 09/22/2007, 04:21 PM
  4. High idle question
    By zadam123 in forum VX Troubleshooting...
    Replies: 15
    Last Post: 01/18/2007, 06:14 PM
  5. RPM to high at idle
    By ThunderChicken in forum VX Troubleshooting...
    Replies: 6
    Last Post: 09/23/2004, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
$lv_vb_eventforums_eventdetails