Results 1 to 12 of 12

Thread: TOD Check Light On JDV VX

  1. #1
    Member Since
    Jan 2009
    Location
    97 Jap Import, Black BEAST
    Posts
    1,515
    Thanked: 0

    TOD Check Light On JDV VX

    My check light is flashing and i have had a search and looked at others problems but alot of the easy fixes are tyres etc which don't apply.

    My TOD is flashing i 2WD mode constantly. When i put it in TOD the front wheels wont light up and the check light continuies to flash

    In L range the front wheel lights light up and are engaged and the Check light continues to flash.


    Anyone got any ideas? Where are the connectors?

    Also, does the scan guage read these codes or do i need to jack the No.8 pin to get the check light to flash the error code?
    Speed Thrills, Boredom Kills!!

  2. #2
    Member Since
    Feb 2007
    Location
    2000 Proton VX - 0776
    Posts
    9,258
    Thanked: 0
    My TOD check light started flashing recently. When I first start it, all is fine but after a short time it starts flashing again. Since it only happens after the vehicle heats up, I'm wondering if one of the connectors for the TOD is too close to the exhaust. I've only taken a quick look under the vehicle & didn't find anything. Guess I'll have to do a more thorough inspection.

    Keep us posted if you locate the gremlin. I'll do the same.

    Tom


    Put a smiley after you say that Bub.

  3. #3
    Member Since
    Oct 2008
    Location
    UK Sunburst Ltd 000/175
    Posts
    146
    Thanked: 0

    shaft rotation sensor

    I haven't had this problem but it sounds very similar to an problem another UK owner had (unfortunately I haven't got her email address immediately to hand and she has since sold her VX). It transpired that it was a shaft rotation sensor - where and which one I can't remember (sorry but it may give u a clue where to look) but she said that it was a 'common problem' (!?). I'll try to track down that email address 4 U.

    Kirk

  4. #4
    Member Since
    Jan 2009
    Location
    97 Jap Import, Black BEAST
    Posts
    1,515
    Thanked: 0
    Thanks mate, spends alot of time with mud on it and i washed it last night so could well be a sensor. Is there a list of where the sensors are?

  5. #5
    Member Since
    Jan 2009
    Location
    1999, Ebony Black, VX, 1614
    Posts
    1,852
    Thanked: 1
    Perhaps this......??????

    TSB Click Here

  6. #6
    Member Since
    Oct 2008
    Location
    UK Sunburst Ltd 000/175
    Posts
    146
    Thanked: 0

    my isuzu parts

    Sorry C.Rocket haven't been able to track down the email of the UK owner who may have had a similar problem. As regard to sensors inm general, have you visited the website www.myisuzuparts.com ? It covers the US VX but there are lots of pics, a search engine and part lists which might help with tracking down sensors (if that is the problem) but remember the US TOD is slightly different to the JDM versions.

    Kirk

  7. #7
    Member Since
    Mar 2008
    Location
    1999 (2001) Radiant Red 157/175 "lil pwny"
    Posts
    219
    Thanked: 0
    hi mate, i can only suggest that you get under your front end and have a look at your front diff. you want to check that your sensor plugs have a good connection. you have been in mudd and krudd latly so you may given this a bit of a knock.

    All i got sorry

    (on a side note, i did loose my 4wd to my front diff a little while ago, turned out to be a crushed vucumm hose. though it did not affect my tod display)

  8. #8
    Member Since
    Dec 2004
    Location
    Former owner of Supercharged #0604, now in withdrawal
    Posts
    1,484
    Thanked: 0
    I have had the ToD check light come on twice, and both times it was because the sensor wiring harness had grounded out somewhere - the first time the harness melted on the cats after a clip broke, the second time it was just doe to wear where the harness passed through a hold in the frame somewhere underneath.

    Good luck!

  9. #9
    Member Since
    Jan 2009
    Location
    97 Jap Import, Black BEAST
    Posts
    1,515
    Thanked: 0
    Quote Originally Posted by JAMAS View Post
    Perhaps this......??????

    TSB Click Here
    Strange you suggest that, my airbag light has started to come on speradicaly. !!

    I will check it out.



    The TOD is fine today?? VERY strange !!! i have downloaded all the literature on the TOD system and im going to read up on it incase something does go wrong.

  10. #10
    Member Since
    Jan 2009
    Location
    97 Jap Import, Black BEAST
    Posts
    1,515
    Thanked: 0
    Quote Originally Posted by Hetzer View Post
    hi mate, i can only suggest that you get under your front end and have a look at your front diff. you want to check that your sensor plugs have a good connection. you have been in mudd and krudd latly so you may given this a bit of a knock.

    All i got sorry

    (on a side note, i did loose my 4wd to my front diff a little while ago, turned out to be a crushed vucumm hose. though it did not affect my tod display)


    I am confused by the mension of vacume hoses?? i saw someone else mension it too. I thought the system was fully electronic?? The electromagnetic clutch simply engages the front wheels to a degree depending on road conditions which are fed to it from front and rear prop speed sensors, TPS sensor and brake sensor?

    When in Low range the clutch is bypassed by a drive chain.
    Last edited by crotchrocket : 06/04/2009 at 05:02 AM

  11. #11
    Member Since
    Jan 2009
    Location
    97 Jap Import, Black BEAST
    Posts
    1,515
    Thanked: 0
    OH, and thanks to the site for all the info available and the TOD info downloads!!!!! Thought i'd pop $10 into the donations bucket for the privelage

  12. #12
    Member Since
    Jan 2007
    Location
    1997 Silver JDM
    Posts
    278
    Thanked: 0
    Quote Originally Posted by crotchrocket View Post
    Strange you suggest that, my airbag light has started to come on speradicaly. !!

    I will check it out.



    The TOD is fine today?? VERY strange !!! i have downloaded all the literature on the TOD system and im going to read up on it incase something does go wrong.
    It sounds like something got wet and has now dried out. You may want to get underneath and have a bit of a session checking over connections and drowning them in WD40...

    My gear display was doing some interesting stuff on Sunday but I'm told it was behaving again on Tuesday.

    A

Similar Threads

  1. tod check light
    By zadam123 in forum VX Troubleshooting...
    Replies: 9
    Last Post: 11/10/2016, 04:16 PM
  2. check TOD light
    By fred78 in forum VX Troubleshooting...
    Replies: 4
    Last Post: 10/20/2014, 01:45 PM
  3. check light and abs
    By FlyingV77 in forum VX Troubleshooting...
    Replies: 2
    Last Post: 05/28/2013, 05:23 AM
  4. TOD Check Light
    By saberwolf in forum VX Troubleshooting...
    Replies: 10
    Last Post: 12/28/2008, 10:48 PM
  5. Tod Check Light Help!!!
    By ron in forum VX Troubleshooting...
    Replies: 12
    Last Post: 07/02/2007, 11:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
$lv_vb_eventforums_eventdetails